
Sonora Grade 4-1 

Chapter 4  One Student’s Grades, 
So Many Views 

 

 Slicing and dicing a student’s record 

A few years ago, TV commercials for the the Veg-o-matic, 
a vegetable-cutting kitchen implement touted, “It slices! It 
dices!  It even cuts Julienne French fries!” 

The commercials had an infectious enthusiasm.  Your TV 
screen demonstrated the one and only Veg-o-matic ripping 
into cucumbers, celery and mushrooms, slicing and dicing 
every which way, thick and thin, straight and diagonal. 

The do-it-all-in-a-snap flexibility made this oddball product 
a rousing success for Ronco (named by Ron, the inventor-
entrepreneur-huckster who started the company). 

So what, you might well ask, has this Veg-o-matic to do 
with TUSD students, their grades, and Sonora software? 

That’s easy.  Look at the Student Grade - Transcript 
section of Sonora Grade as the View-o-matic with which 
you can slice and dice the information on a student’s grades 
effortlessly, just about any way you like. 

Look at grades from the most recent back to earlier 
semesters.  Check grades by department or by grade level.  
Slice and dice effortlessly, all for just $19.95 plus shipping 
and... sorry, we got our wires crossed again. 

That brings us to the infamous Ronco Pocket Fisherman.  
The problem was that the pond water leaked out of people’s 
pockets.  This caused embarrassing stains for the humans, 
not to mention making life mighty tough on the fish. 
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 Individual student overview 

Sonora Grade gives you many ways to look at student 
progress.  In the last chapter, we checked grades from the 
classroom perspective. 

Now we shift our focus to the individual student’s grades, 
both current and past.  We view the grades from this school 
year plus the student’s transcript at this school. 

This viewpoint enables us to analyze grades for patterns 
that help explain the student’s strengths and weaknesses.  
This could be invaluable to a guidance counselor helping 
the student establish more consistent performance so that 
he or she can maintain progress toward graduation. 

The transcript gives us a broader perspective of how the 
student’s current grades relate to his or her performance 
over the past few years.   

With such tools, we can hope to understand the student’s 
personal patterns.  This enables us to create circumstances 
and the provide tools for students to succeed. 

 Open to the Student Grades section 

 

We looked at logging in to Sonora Grade earlier in this 
manual.  You always need to begin there, so if you’re 
unsure of how to get inside the program, mosey on back to 
Chapter 2 and check out the login procedure. 

Use the File menu to reach the individual parts of the 

program.  Select File > Student Grades - Transcript 
(Alt-F, G).  From here it’s off to recordville where we’re 
back in the heart of the student grades. 

We’ve cautioned you before about confidentiality, but it’s 
important enough to bear repeating.  This is the most 

sensitive part of all school records.  You are required by 
law to uphold every student’s privacy.   

Besides, common decency demands you keep mum about 
personal records.  Now let’s get on with it. 
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 Student search 

As usual in the Sonora systems, you begin with a search.   

As the Student Grade - Transcript section of the 

program comes into view, it’s quickly covered by the Find 
Student by Name screen.  That’s Sonora’s way of 
politely but firmly asking for information.  Just whose 
grades do you want to see? 

Figure Chapter 4 -1: Finding the student’s record to 

examine 

 

Begin in the Last Name space.  Type enough letters of the 
student’s last name to locate that student in the records. 

Click Find (Alt-E, N or F3).  The computer retrieves 
matching names.  Now click on the line with the student we 
select.  In this case that’s Kimberly Clark, heiress to the 
Kleenex fortune, which is certainly nothing to sneeze at. 

When you’ve selected the student’s line, click OK (Alt-O).  
A shortcut is to double-click on the student’s line. 

Kimberly’s recorded grades come up on the Current 
Grades screen.  Her matriculation number and name 
appear on the title bar at the top of your screen.  That’s to 
help you stay oriented. 

Now we’re getting somewhere. 

Enter enough letters of 
the student’s last name 

here to find him/her 

Click the Find button to 
look for those letters in 

the student records 

Matching student names 
appear in this list box 

Click on the line with the 
student you were looking 

for and... 

click OK to load Kimberly 
Clark’s  information on 

the main screen 
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 First slice 

Kimberly’s most recent grades fill in the screen that looks 
suspiciously like a spreadsheet.  That’s because the 
programmers thought you Excel addicts might enjoy 
finding a familiar hangout here in Sonora Grade. 

Let’s get familiar with the screen. 

At the top are the standard title bar and name of the file you 
have open, which in this case is Kimberly Clark and her 
matric number.  Beneath that are the standard Windows 
drop-down menus, which we’ll be using soon.   

The next row is the same Sonora toolbar you may have 
seen in all other Sonora applications.  The toolbar contains 
shortcuts for the commands you use most often. 

Unlike most of the Sonora programs, Grade uses the drop-

down View menu instead of the usual toolbar to slice and 
dice the data.  What’s worse, the software is just plain 
useless when it comes to cutting Julienne fries. 

Figure Chapter 4 -2: First glance at Kimberly Clark's 

grades 

Command center: 
drop-down menus 

and Sonora  
toolbar 

This year’s 
classes 

Current grades 

Details on the grade 
highlighted above 
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 The grade spreadheet 

Finally, we reach the Holy Grail of our search: Kimberly 
Clark’s grades.  You may emit an exultant shout, but please 
don’t disturb people working around you. 

Notice the spreadsheet-like look on this part of the screen.  
If you use Excel, this probably feels like Old Home Week. 
Letter grades appear in “cells” as in a spreadsheet. Your 
cursor becomes a plus-sign when it’s over the grade sheet. 

The “active cell” with your cursor is outlined in bright 
yellow.  Beneath the spreadsheet section are details that tell 
you more about the grade in the active cell. 

Before we look more closely at the grade section itself, bear 
in mind that this is where we do all that slicing and dicing.  
You don’t like how the screen is set up now?  Worry not, 
neither shalt thou fret.  You can change it practically 
effortlessly (as they say in the Veg-o-matic commercials). 

Still, let’s see what we have to start. 

Figure Chapter 4 -3: First look at Kimberly's grades 

Across the top of the sheet are Kim’s matriculation number, 
her full name and grade.   

The next line down labels the columns, starting with the 
class description and then showing each grading period.   

Notice that there are more columns than can fit on the 
screen at once.  A horizontal scroll bar at the bottom lets 
you see the rest of the grading periods on your spreadsheet. 

Down the left side are the classes she has this school year.  
Notice that Coed Phys Ed has grades for separate semesters 
on separate lines. 
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 A glance to the right 

Now let’s get a look at what the scroll bar can show us on 
the right side of the screen.  Yes, we have more grading 
periods.  Click on the scroll bar to get a look at them.   

If you think there are too many grading periods on this 
sheet, don’t worry.  Your opportunity to change them will 
come soon enough. 

Figure Chapter 4 -4: Scroll right to see more grading 

periods and the teachers for each class 

 

On the far right-hand edge of the sheet is name of the 
teacher who assigned the grades.  So when you’re looking 
for the party who assigned the grade, scroll all the way to 
the right edge of the sheet, where the teacher’s name 
appears opposite the class name.   

This view lets you see all the student’s teachers at a glance.  
Other views let you see one class at a time, depending on 
the grade cell you select.   

We could tantalize you further, but it’s time to move along 
to slicing and dicing the spreadsheet.   

Get ready.  We can show include nearly everything your 
heart desires, except maybe finding that ever-so-elusive 
meaning of life. 

Neither can we help you get back to Kansas from Oz. 
Rumor has it, though, that a triple-click on ruby slippers are 
useful tool, especially when applied with the mantra, 
“There’s no place like TUSD, there’s no place like home.” 
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 View-o-matic slicing and dicing 

Grades and their context being all-important, we’ve got a 
plethora of options to see how teachers evaluate Kim Clark. 

 

It all happens under the pull-down View (Alt-V) menu.  
Let’s see just how you would like your data served today.   

Your first three choices in the View menu are toggle 

switches that alternate between off and on.   

A check mark in front of the Course Number, Grade 
Level or Grade Detail selections tells you those choices 
are set to on.  Choose it again and you turn off that 
selection.  Got it? 

Let’s show you how it works.  Click the View menu and 

select Course Number (Alt-V, N).  The school’s course 
numbers appear to the left of the spreadsheet’s course 
descriptions.  If you have no need for these code numbers, 
click the command again and the course numbers 
disappear. 
 

          

 
 

The same happens with View > Grade Level (Alt-V, L). 
On the far left edge of the spreadsheet, you see what grade 
Kim was in when she took the course. 

           

 
Notice that by adding this information, the new columns 
push the grades themselves farther over to the right.  
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 Finding details on a grade cell 

If you want to see the grade level, course numbers, teacher 
and other such details about the active cell instead of all the 
classes on the spreadsheet, get that information at the at the 
bottom of the screen.   

When you first open the Student Grade - Transcript 
section, Grade Detail is already on. 

 

 

 

Figure Chapter 4 -5: The Grade Level, Course 
Number and Grade Detail options are active, 

confirmed by the check marks on the View menu 

Grade details appear below the grade sheet.  Boxes identify 
the class, school year, term, school, teacher and grade. 

Below that is more information on the grade for the course, 
including space for a citizenship grade or a teacher 
comment. In the case of young Kim Clark, none of the 
teachers felt it necessary to use either one. 

If you find all this is unnecessary clutter on your screen or 
you have a slower computer, you can turn off Grade Detail.   

From the pull-down menu select View > Grade Detail 
(Alt-V, D). The space clears at the bottom of the screen. 

Grade details here 
tell more about the 

grade highlighted 
above 
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 Power slicing and dicing options 

You want still more detail?  You want to select which grade 
periods you see?  You want to create settings that you can 
count on every time you open Sonora Grade? 

No problem.  In fact, we can get it for you wholesale.  Just 
step right up to the View-o-matic and place your order. 
We’ll slice and dice the data just the way you like it. 

 

From the pull-down menus, select View > Options  

(Alt-V, O).  This command opens a dialog box that offers  
you many more choices on how to see the student’s grades. 

In fact, we have so many choices here that we have a dialog 
jammed full so that it could contain them all.   

We can choose how to sort the grades, which grading 
periods to include, and whether to keep those settings as 
our standard view of student grades. 

 
Figure Chapter 4 -6: Fine tuning what you see and how 

you see it 

This small box presents a plethora of possibilities.  Here 
you choose how you want to look at grades right now.  But 
by saving a view as the default setting, you determine what 
you see every time you open Sonora Grade. 

 

Select the sorting 
method here 

Highlight as many 
grading periods as 

you want to see here 

To see the information 
this way every time,  
save the selections 
above as a default 

setting here 

Click OK to put your 
changes into effect 
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 Sort by Grade or Department? 

Your first choice is how you sort the student’s record.  The 
default setting—that is, the way things are set until you 

change them—is sorting by grade level as you have seen. 

When you sort by department, you see the courses this 
student has taken grouped in such academic credit areas as 
foreign language, science, social studies, etc. 

To change to the department view, click on the 

Department radio button.  If you are making other 
changes to the view screen, go ahead.  Then, when all your 

changes are set in this box, click OK (Alt-O). 

The screen redraws the spreadsheet to reflect the setting. 

 

 

 Up or down? 

You’ve been looking at the student’s record in the order in 
happened, from the earliest to the latest. 

But you’re not locked into that perspective.  If you’re more 
interested in the student’s most recent grades, you can bring 
them to the top and work backwards through the records. 

This is the Descending view. 

To get there, click on the arrow to the right of the 

Ascending label.  Then click on the Descending line. 

Again, when you click OK (Alt-O or just Enter), the 
computer redraws the screen to comply with your request.  
Too bad students and co-workers aren’t as responsive, 
don’t you think? 
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 Which grading periods? 

 
 

This one is really fun.  The list box contains every possible 
grading period.   

You can select just one grading period, all of them, or pick 
and choose which of those grading periods you want to see 
and which ones you don’t.  

For example, you can include progress reports in each 
quarter, or just the quarters you specify.   

Include or exclude final reports from each quarter, each 
semester and each full year. 

If your school is on a year-round schedule, choose the three  
trimesters and exclude the rest. 

 
Figure Chapter 4 -7: Select trimesters from the 

Options menu and you get this view 

To select the first grading period to use in the spreadsheet, 
click a line with that grading period.   

To add more grading periods to include on the sheet, hold 

down the Control (Ctrl) key and click on as many other of 
the lines as you care to use.   

This way you can include just one grading period, every 
possible grading period, or as many of the possible grade 
periods as you care to see.  It’s entirely up to you. 
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 Just this once, or until further notice? 

Finally we arrive at the power setting.  You can choose the 
views we just discussed above for just this time.   

That’s done by clicking on those choices, then sliding 

directly to the OK button (Alt-O). 

But there’s another way.  You can choose to keep these 
settings for every time you look in Sonora Grade.   

 
 

Here’s how: after you choose your preferences in the 

settings, roll your mouse over to the Save as Default 
section of your Options screen.   

Lock in ascending or descending order.  Click Sort Order. 

To lock in your new specifications for the grading periods 

you see each time, click Grade Period. 

If your last View setting included sorting by department, 
the dimmed option you see here will brighten for you to 

use.  Then click the box in front of Department. 

 
 

 
 

Finally, to execute the choices you’ve made by clicking all 

those buttons, click OK.  This saves the new default 
settings—until, that is, you decide to change them again. 

Or you could chicken out right here. To do that, cluck, lay a 

few eggs and click Cancel (Alt-C).  The settings return 
next time just as they were when you started out this time. 

 Next Steps 

Take a close look at your hands and fingers.  For all that 
slicing and dicing, you don’t have a single cut to show for 
it.  That’s part of the beauty of computer technology.   

We’ve come some distance we’ve come in this chapter, but  

we’re not finished with the Student Grade - Transcript 
section of the Sonora Grade menu. 

Next chapter we take a stroll with the ghosts of grades part 
as we delve into the transcript features.  See you there.  
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